CVE-2022-26127

NameCVE-2022-26127
DescriptionA buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3797-1
Debian Bugs1008010

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
frr (PTS)buster6.0.2-2+deb10u1vulnerable
buster (security)7.5.1-1.1+deb10u2fixed
bullseye (security), bullseye7.5.1-1.1+deb11u2vulnerable
bookworm, bookworm (security)8.4.4-1.1~deb12u1fixed
sid, trixie10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
frrsourcebuster7.5.1-1.1+deb10u2DLA-3797-1
frrsource(unstable)8.4.1-11008010

Notes

[bullseye] - frr <no-dsa> (Minor issue)
https://github.com/FRRouting/frr/issues/10487
Fixed by https://github.com/FRRouting/frr/pull/10494

Search for package or bug name: Reporting problems