CVE-2022-26129

NameCVE-2022-26129
DescriptionBuffer overflow vulnerabilities exist in FRRouting through 8.1.0 due to wrong checks on the subtlv length in the functions, parse_hello_subtlv, parse_ihu_subtlv, and parse_update_subtlv in babeld/message.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1008010

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
frr (PTS)buster6.0.2-2+deb10u1vulnerable
bullseye7.5.1-1.1vulnerable
sid8.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
frrsource(unstable)(unfixed)1008010

Notes

[bullseye] - frr <no-dsa> (Minor issue)
[buster] - frr <no-dsa> (Minor issue)
https://github.com/FRRouting/frr/issues/10503

Search for package or bug name: Reporting problems