CVE-2022-26981

NameCVE-2022-26981
DescriptionLiblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1008009

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)stretch3.0.0-3+deb9u4vulnerable
buster3.8.0-2vulnerable
bullseye3.16.0-1vulnerable
bookworm, sid3.21.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)(unfixed)1008009

Notes

[bullseye] - liblouis <no-dsa> (Minor issue)
[buster] - liblouis <no-dsa> (Minor issue)
https://github.com/liblouis/liblouis/issues/1171

Search for package or bug name: Reporting problems