CVE-2022-27148

NameCVE-2022-27148
DescriptionGPAC mp4box 1.1.0-DEV-rev1663-g881c6a94a-master is vulnerable to Integer Overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)buster0.5.2-426-gc5ad4e4+dfsg5-5fixed
bullseye (security), bullseye1.0.1+dfsg1-4+deb11u1fixed
bookworm, sid2.0.0+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsourcestretch(unfixed)end-of-life
gpacsourcebuster(not affected)
gpacsourcebullseye(not affected)
gpacsource(unstable)2.0.0+dfsg1-2

Notes

[bullseye] - gpac <not-affected> (Vulnerable code not present)
[buster] - gpac <not-affected> (Vulnerable code not present)
[stretch] - gpac <end-of-life> (No longer supported in LTS)
https://github.com/gpac/gpac/issues/2067
https://github.com/gpac/gpac/commit/0cd19f4db70615d707e0e6202933c2ea0c1d36df (v2.0.0)

Search for package or bug name: Reporting problems