CVE-2022-27416

NameCVE-2022-27416
DescriptionTcpreplay v4.4.1 was discovered to contain a double-free via __interceptor_free.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpreplay (PTS)buster4.3.1-1vulnerable
bullseye4.3.3-2vulnerable
bookworm4.4.1-2fixed
sid4.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpreplaysource(unstable)4.4.1-1unimportant

Notes

https://github.com/appneta/tcpreplay/issues/702
https://github.com/appneta/tcpreplay/pull/711
https://github.com/appneta/tcpreplay/commit/9297ac29af91324e3f94580b8ffc2a40a4d59e98 (v4.4.1)
https://github.com/appneta/tcpreplay/commit/45cb2ac23213861749d82ad3524f46e347d308a3 (v4.4.1)
NOTE: Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems