CVE-2022-27666

NameCVE-2022-27666
DescriptionA heap buffer overflow flaw was found in IPsec ESP transformation code in net/ipv4/esp4.c and net/ipv6/esp6.c. This flaw allows a local attacker with a normal user privilege to overwrite kernel heap objects and may cause a local privilege escalation threat.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5127-1, DSA-5173-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster, buster (security)4.19.249-2fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
bookworm5.19.6-1fixed
sid5.19.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster4.19.249-2DSA-5173-1
linuxsourcebullseye5.10.113-1DSA-5127-1
linuxsource(unstable)5.16.18-1

Notes

[stretch] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/ebe48d368e97d007bfeb76fcb065d6cfc4c96645 (5.17-rc8)

Search for package or bug name: Reporting problems