CVE-2022-2819

NameCVE-2022-2819
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0211.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2fixed
buster (security)2:8.1.0875-5+deb10u4fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.1000-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster(not affected)
vimsource(unstable)2:9.0.0229-1unimportant

Notes

[buster] - vim <not-affected> (The vulnerable code was introduced later)
https://huntr.dev/bounties/0a9bd71e-66b8-4eb1-9566-7dfd9b097e59
https://github.com/vim/vim/commit/d1d8f6bacb489036d0fd479c9dd3c0102c988889 (v9.0.0211)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems