DescriptionWeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where or is changed without a WeeChat restart.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)buster2.3-1+deb10u1fixed
bookworm, sid3.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsourcestretch(not affected)
weechatsourcebuster(not affected)
weechatsourcebullseye(not affected)


[bullseye] - weechat <not-affected> (Vulnerable code introduced later)
[buster] - weechat <not-affected> (Vulnerable code introduced later)
[stretch] - weechat <not-affected> (Vulnerable code introduced later)
Fixed by: (v3.4.1) introduced by: (v3.2-rc1)

Search for package or bug name: Reporting problems