CVE-2022-28352

NameCVE-2022-28352
DescriptionWeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)buster2.3-1+deb10u1fixed
bullseye3.0-1+deb11u1fixed
bookworm, sid3.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsourcestretch(not affected)
weechatsourcebuster(not affected)
weechatsourcebullseye(not affected)
weechatsource(unstable)3.4.1-1

Notes

[bullseye] - weechat <not-affected> (Vulnerable code introduced later)
[buster] - weechat <not-affected> (Vulnerable code introduced later)
[stretch] - weechat <not-affected> (Vulnerable code introduced later)
https://weechat.org/doc/security/WSA-2022-1/
https://github.com/weechat/weechat/issues/1763
Fixed by: https://github.com/weechat/weechat/commit/710247891cdfd4e66ee6d1715e93626def6871f1 (v3.4.1)
weechat.network.gnutls_ca_system/gnutls_ca_user introduced by: https://github.com/weechat/weechat/commit/c588ee21bc8fd33678893d5c67616033281032e3 (v3.2-rc1)

Search for package or bug name: Reporting problems