CVE-2022-28368

NameCVE-2022-28368
DescriptionDompdf 1.2.1 allows remote code execution via a .php file in the src:url field of an @font-face Cascading Style Sheets (CSS) statement (within an HTML input file).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs1010090

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-dompdf (PTS)stretch0.6.2+dfsg-3fixed
buster0.6.2+dfsg-3vulnerable
bookworm, sid, bullseye0.6.2+dfsg-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-dompdfsourcestretch(not affected)
php-dompdfsource(unstable)(unfixed)1010090

Notes

[stretch] - php-dompdf <not-affected> (Vulnerable code not present)
https://snyk.io/blog/security-alert-php-pdf-library-dompdf-rce/
https://positive.security/blog/dompdf-rce
https://github.com/dompdf/dompdf/issues/2598
https://github.com/dompdf/dompdf/pull/2808
https://github.com/dompdf/dompdf/commit/4c70e1025bcd9b7694b95dd552499bd83cd6141d (v1.2.1)

Search for package or bug name: Reporting problems