CVE-2022-2849

NameCVE-2022-2849
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0220.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0626-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.0229-1unimportant

Notes

https://huntr.dev/bounties/389aeccd-deb9-49ae-9b6a-24c12d79b02e
https://github.com/vim/vim/commit/f6d39c31d2177549a986d170e192d8351bd571e2 (v9.0.0220)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems