CVE-2022-2850

NameCVE-2022-2850
DescriptionSIGSEGV in sync_repl
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1018054

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)buster1.4.0.21-1vulnerable
bullseye1.4.4.11-2vulnerable
bookworm, sid2.0.15-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)(unfixed)1018054

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=2118691
https://github.com/389ds/389-ds-base/issues/4711#issuecomment-1205100979
https://github.com/389ds/389-ds-base/issues/5418
https://github.com/389ds/389-ds-base/commit/513a763b551848e5532ec22bb0086464aa09252f (main)
https://github.com/389ds/389-ds-base/commit/19632a4b8de5ba0abe05cdfe514a7ada07d0c299 (389-ds-base-2.0)
https://github.com/389ds/389-ds-base/commit/be599560c9bbb17570f5eeb5aac1919a8d333567 (389-ds-base-1.4.4)
https://github.com/389ds/389-ds-base/commit/bd566957f85c889f13cd24f903c91c16c955acbd (389-ds-base-1.3.10)
Results from an incomplete fix for CVE-2021-3514

Search for package or bug name: Reporting problems