CVE-2022-28738

NameCVE-2022-28738
DescriptionA double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby2.5 (PTS)buster, buster (security)2.5.5-3+deb10u4fixed
ruby2.7 (PTS)bullseye (security), bullseye2.7.4-1+deb11u1fixed
ruby3.0 (PTS)bookworm, sid3.0.4-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby2.3source(unstable)(not affected)
ruby2.5source(unstable)(not affected)
ruby2.7source(unstable)(not affected)
ruby3.0source(unstable)3.0.4-11009958

Notes

- ruby2.7 <not-affected> (Vulnerable code not present)
- ruby2.5 <not-affected> (Vulnerable code not present)
- ruby2.3 <not-affected> (Vulnerable code not present)
https://github.com/ruby/ruby/commit/052ec6d2585c3ace95671013d336f5543624ef3d (v3_0_4)
https://github.com/ruby/ruby/commit/73f45e5e96ccc13a131f7c0122cf8600ce5b930f (v3_1_2)
https://www.ruby-lang.org/en/news/2022/04/12/double-free-in-regexp-compilation-cve-2022-28738/

Search for package or bug name: Reporting problems