CVE-2022-28948

NameCVE-2022-28948
DescriptionAn issue in the Unmarshal function in Go-Yaml v3 causes the program to crash when attempting to deserialize invalid input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1011338

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-gopkg-yaml.v3 (PTS)bullseye3.0.0~git20200121.a6ecf24-3vulnerable
bookworm, sid3.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-gopkg-yaml.v3source(unstable)3.0.1-11011338

Notes

https://github.com/go-yaml/yaml/issues/666
https://github.com/go-yaml/yaml/commit/8f96da9f5d5eff988554c1aae1784627c4bf6754 (v3.0.0)

Search for package or bug name: Reporting problems