CVE-2022-29023

NameCVE-2022-29023
DescriptionA buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openrazer (PTS)buster2.4.0+dfsg-1vulnerable
bullseye2.9.0+dfsg-1vulnerable
bookworm3.4.0+dfsg-2.1fixed
sid3.5.0+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openrazersource(unstable)3.3.0+dfsg-1unimportant

Notes

https://github.com/openrazer/openrazer/pull/1790
https://github.com/openrazer/openrazer/commit/7e8a04feb378a679f1bcdcae079a5100cc45663b (v3.3.0)
Negligible security impact

Search for package or bug name: Reporting problems