CVE-2022-29181

NameCVE-2022-29181
DescriptionNokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-nokogiri (PTS)buster1.10.0+dfsg1-2vulnerable
bullseye1.11.1+dfsg-2vulnerable
bookworm, sid1.13.5+dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-nokogirisource(unstable)(unfixed)unimportant

Notes

https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-xh29-r2w5-wx8m
https://github.com/sparklemotion/nokogiri/commit/83cc451c3f29df397caa890afc3b714eae6ab8f7 (v1.13.6)
Binary package do not contain the Java extension, as the package is built with
export DH_RUBY_GEM_INSTALL_EXCLUDE = ext/java/*

Search for package or bug name: Reporting problems