CVE-2022-2929

NameCVE-2022-2929
DescriptionIn ISC DHCP 1.0 -> 4.4.3, ISC DHCP 4.1-ESV-R1 -> 4.1-ESV-R16-P1 a system with access to a DHCP server, sending DHCP packets crafted to include fqdn labels longer than 63 bytes, could eventually cause the server to run out of memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3146-1, DSA-5251-1
Debian Bugs1021320

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)buster4.4.1-2+deb10u1vulnerable
buster (security)4.4.1-2+deb10u2fixed
bullseye4.4.1-2.3vulnerable
bullseye (security)4.4.1-2.3+deb11u1fixed
bookworm, sid4.4.3-P1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isc-dhcpsourcebuster4.4.1-2+deb10u2DLA-3146-1
isc-dhcpsourcebullseye4.4.1-2.3+deb11u1DSA-5251-1
isc-dhcpsource(unstable)4.4.3-2.11021320

Notes

https://www.openwall.com/lists/oss-security/2022/10/05/1
https://downloads.isc.org/isc/dhcp/4.4.3-P1/patches/
https://downloads.isc.org/isc/dhcp/4.1-ESV-R16-P2/patches/
https://kb.isc.org/docs/cve-2022-2929

Search for package or bug name: Reporting problems