CVE-2022-2980

NameCVE-2022-2980
DescriptionNULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.0259.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0626-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.0626-1unimportant

Notes

https://huntr.dev/bounties/6e7b12a5-242c-453d-b39e-9625d563b0ea
https://github.com/vim/vim/commit/80525751c5ce9ed82c41d83faf9ef38667bf61b1 (9.0.0259)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems