CVE-2022-29970

NameCVE-2022-29970
DescriptionSinatra before 2.2.0 does not validate that the expanded path matches public_dir when serving static files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014717

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-sinatra (PTS)buster2.0.5-4vulnerable
bullseye2.0.8.1-2vulnerable
bookworm, sid2.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-sinatrasource(unstable)2.2.2-11014717

Notes

https://github.com/sinatra/sinatra/commit/462c3ca1db53ed3cfc394cf5948e9c948ad1c10e (v2.2.0)

Search for package or bug name: Reporting problems