CVE-2022-3016

NameCVE-2022-3016
DescriptionUse After Free in GitHub repository vim/vim prior to 9.0.0286.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0626-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.0626-1unimportant

Notes

https://huntr.dev/bounties/260516c2-5c4a-4b7f-a01c-04b1aeeea371
https://github.com/vim/vim/commit/6d24a51b94beb1991cddce221f90b455e2d50db7 (v9.0.0286)
Crash in CLI toool, no security impact

Search for package or bug name: Reporting problems