CVE-2022-30522

NameCVE-2022-30522
DescriptionIf Apache HTTP Server 2.4.53 is configured to do transformations with mod_sed in contexts where the input to mod_sed may be very large, mod_sed may make excessively large memory allocations and trigger an abort.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1012513

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8fixed
buster (security)2.4.38-3+deb10u7vulnerable
bullseye2.4.54-1~deb11u1fixed
bullseye (security)2.4.52-1~deb11u2vulnerable
bookworm2.4.54-3fixed
sid2.4.54-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcebuster2.4.38-3+deb10u8
apache2sourcebullseye2.4.54-1~deb11u1
apache2source(unstable)2.4.54-11012513

Notes

https://www.openwall.com/lists/oss-security/2022/06/08/6
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2022-30522
https://github.com/apache/httpd/commit/db47781128e42bd49f55076665b3f6ca4e2bc5e2
https://github.com/apache/httpd/commit/96c75bba15b6ce20eb8d34aad717a046c000b233

Search for package or bug name: Reporting problems