CVE-2022-30556

NameCVE-2022-30556
DescriptionApache HTTP Server 2.4.53 and earlier may return lengths to applications calling r:wsread() that point past the end of the storage allocated for the buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1012513

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster, buster (security)2.4.38-3+deb10u7vulnerable
bullseye2.4.53-1~deb11u1vulnerable
bullseye (security)2.4.52-1~deb11u2vulnerable
bookworm, sid2.4.54-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.54-11012513

Notes

[bullseye] - apache2 <no-dsa> (Minor issue; can be fixed in point release)
[buster] - apache2 <no-dsa> (Minor issue; can be fixed in point release)
https://www.openwall.com/lists/oss-security/2022/06/08/7
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2022-30556
https://github.com/apache/httpd/commit/3a561759fcb37af179585adb8478922dc9bc6a85

Search for package or bug name: Reporting problems