CVE-2022-30629

NameCVE-2022-30629
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4vulnerable
golang-1.15 (PTS)bullseye1.15.15-1~deb11u4vulnerable
golang-1.17 (PTS)bookworm, sid1.17.11-1fixed
golang-1.18 (PTS)bookworm, sid1.18.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(unfixed)
golang-1.15source(unstable)(unfixed)
golang-1.17source(unstable)1.17.11-1
golang-1.18source(unstable)1.18.3-1
golang-1.7sourcestretch(not affected)
golang-1.7source(unstable)(unfixed)
golang-1.8sourcestretch(not affected)
golang-1.8source(unstable)(unfixed)

Notes

[bullseye] - golang-1.15 <no-dsa> (Minor issue)
[buster] - golang-1.11 <no-dsa> (Minor issue)
[stretch] - golang-1.8 <not-affected> (Vulnerable code - TLS1.3 - introduced later)
[stretch] - golang-1.7 <not-affected> (Vulnerable code - TLS1.3 - introduced later)
https://groups.google.com/g/golang-announce/c/TzIC9-t8Ytg
https://go.dev/issue/52814
https://github.com/golang/go/commit/c838098c327a1b6d63446f4722e943b02d235d78 (go1.18.3)
https://github.com/golang/go/commit/c15a8e2dbb5ac376a6ed890735341b812d6b965c (go1.17.11)

Search for package or bug name: Reporting problems