CVE-2022-30780

NameCVE-2022-30780
DescriptionLighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lighttpd (PTS)stretch1.4.45-1fixed
stretch (security)1.4.45-1+deb9u1fixed
buster, buster (security)1.4.53-4+deb10u2fixed
bullseye (security), bullseye1.4.59-1+deb11u1fixed
bookworm, sid1.4.65-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lighttpdsourcestretch(not affected)
lighttpdsourcebuster(not affected)
lighttpdsource(unstable)1.4.59-1

Notes

[buster] - lighttpd <not-affected> (Vulnerable code introduced later)
[stretch] - lighttpd <not-affected> (Vulnerable code introduced later)
https://podalirius.net/en/cves/2022-30780/
https://github.com/p0dalirius/CVE-2022-30780-lighttpd-denial-of-service
https://redmine.lighttpd.net/issues/3059
Fixed by: https://github.com/lighttpd/lighttpd1.4/commit/b03b86f47b0d5a553137f081fadc482b4af1372d (lighttpd-1.4.59)

Search for package or bug name: Reporting problems