CVE-2022-30974

NameCVE-2022-30974
Descriptioncompile in regexp.c in Artifex MuJS through 1.2.0 results in stack consumption because of unlimited recursion, a different issue than CVE-2019-11413.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mujs (PTS)bullseye1.1.0-1+deb11u1vulnerable
bookworm, sid1.2.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mujssource(unstable)1.2.0-3

Notes

[bullseye] - mujs <no-dsa> (Minor issue)
https://github.com/ccxvii/mujs/issues/162
https://github.com/ccxvii/mujs/commit/160ae29578054dc09fd91e5401ef040d52797e61
https://github.com/ccxvii/mujs/commit/799b62bf065b006e2bcb1c80044eab2b10412ecf

Search for package or bug name: Reporting problems