CVE-2022-31620

NameCVE-2022-31620
DescriptionIn libjpeg before 1.64, BitStream<false>::Get in bitstream.hpp has an assertion failure that may cause denial of service. This is related to out-of-bounds array access during arithmetically coded lossless scan or arithmetically coded sequential scan.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libjpeg (PTS)bullseye0.0~git20210129.91985dc-1vulnerable
bookworm, sid0.0~git20220615.842c7ba-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libjpegsource(unstable)0.0~git20220615.842c7ba-1unimportant

Notes

https://github.com/thorfdbg/libjpeg/issues/70
https://github.com/thorfdbg/libjpeg/commit/ef4a29a62ab48b8dc235f4af52cfd6319eda9a6a
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems