CVE-2022-31783

NameCVE-2022-31783
DescriptionLiblouis 3.21.0 has an out-of-bounds write in compileRule in compileTranslationTable.c, as demonstrated by lou_trace.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1011984

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)buster3.8.0-2vulnerable
bullseye3.16.0-1vulnerable
bookworm, sid3.23.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)3.22.0-11011984

Notes

[bullseye] - liblouis <no-dsa> (Minor issue)
[buster] - liblouis <no-dsa> (Minor issue)
https://github.com/liblouis/liblouis/issues/1214
https://github.com/liblouis/liblouis/commit/2e4772befb2b1c37cb4b9d6572945115ee28630a (v3.22.0)

Search for package or bug name: Reporting problems