CVE-2022-31799

NameCVE-2022-31799
DescriptionBottle before 0.12.20 mishandles errors during early request binding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3048-1, DSA-5159-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-bottle (PTS)buster0.12.15-2+deb10u1vulnerable
buster (security)0.12.15-2+deb10u2fixed
bullseye0.12.19-1vulnerable
bullseye (security)0.12.19-1+deb11u1fixed
bookworm, sid0.12.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-bottlesourcestretch0.12.13-1+deb9u2DLA-3048-1
python-bottlesourcebuster0.12.15-2+deb10u2DSA-5159-1
python-bottlesourcebullseye0.12.19-1+deb11u1DSA-5159-1
python-bottlesource(unstable)0.12.20-1

Notes

Fixed by: https://github.com/bottlepy/bottle/commit/e140e1b54da721a660f2eb9d58a106b7b3ff2f00 (0.12.20)

Search for package or bug name: Reporting problems