CVE-2022-32096

NameCVE-2022-32096
DescriptionRhonabwy before v1.1.5 was discovered to contain a buffer overflow via the component r_jwe_aesgcm_key_unwrap. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted JWE token.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rhonabwy (PTS)bullseye0.9.13-3+deb11u2vulnerable
bookworm1.1.11-1fixed
trixie1.1.13-2fixed
sid1.1.13-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rhonabwysource(unstable)1.1.5-1

Notes

[bullseye] - rhonabwy <no-dsa> (Minor issue)
https://github.com/babelouest/rhonabwy/commit/b4c2923a1ba4fabf9b55a89244127e153a3e549b (1.1.5)

Search for package or bug name: Reporting problems