CVE-2022-32166

NameCVE-2022-32166
DescriptionIn ovs versions v0.90.0 through v2.5.0 are vulnerable to heap buffer over-read in flow.c. An unsafe comparison of “minimasks” function could lead access to an unmapped region of memory. This vulnerability is capable of crashing the software, memory modification, and possible remote execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3168-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)buster2.10.7+ds1-0+deb10u1vulnerable
buster (security)2.10.7+ds1-0+deb10u2fixed
bullseye2.15.0+ds1-2+deb11u1fixed
bookworm, sid2.17.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsourcebuster2.10.7+ds1-0+deb10u2DLA-3168-1
openvswitchsource(unstable)2.13.0+dfsg1-1

Notes

https://github.com/openvswitch/ovs/commit/2ed6505555cdcb46f9b1f0329d1491b75290fc73 (v2.12.0)

Search for package or bug name: Reporting problems