CVE-2022-32189

NameCVE-2022-32189
DescriptionA too-short encoded message can cause a panic in Float.GobDecode and Rat GobDecode in math/big in Go before 1.17.13 and 1.18.5, potentially allowing a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4vulnerable
golang-1.15 (PTS)bullseye1.15.15-1~deb11u4vulnerable
golang-1.18 (PTS)bookworm, sid1.18.8-1fixed
golang-1.19 (PTS)bookworm, sid1.19.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(unfixed)
golang-1.15source(unstable)(unfixed)
golang-1.17source(unstable)1.17.13-1
golang-1.18source(unstable)1.18.5-1
golang-1.19source(unstable)1.19-1

Notes

[buster] - golang-1.11 <postponed> (Limited support, follow bullseye DSAs/point-releases)
https://go.dev/issue/53871
https://groups.google.com/g/golang-nuts/c/DCFSyTGM0wU
https://github.com/golang/go/commit/055113ef364337607e3e72ed7d48df67fde6fc66 (master, go1.19)
https://github.com/golang/go/commit/9240558e4f342fc6e98fec22de17c04b45089349 (go1.18.5)
https://github.com/golang/go/commit/703c8ab7e5ba75c95553d4e249309297abad7102 (go1.17.13)

Search for package or bug name: Reporting problems