CVE-2022-32745

NameCVE-2022-32745
DescriptionA flaw was found in Samba. Samba AD users can cause the server to access uninitialized data with an LDAP add or modify the request, usually resulting in a segmentation fault.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5205-1
Debian Bugs1016449

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)buster2:4.9.5+dfsg-5+deb10u3fixed
buster (security)2:4.9.5+dfsg-5+deb10u5fixed
bullseye2:4.13.13+dfsg-1~deb11u5fixed
bullseye (security)2:4.13.13+dfsg-1~deb11u6fixed
bookworm, bookworm (security)2:4.17.12+dfsg-0+deb12u1fixed
trixie2:4.20.2+dfsg-2fixed
sid2:4.20.2+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcebuster(not affected)
sambasourcebullseye2:4.13.13+dfsg-1~deb11u5DSA-5205-1
sambasource(unstable)2:4.16.4+dfsg-11016449

Notes

[buster] - samba <not-affected> (Only affects 4.13 and later)
https://www.samba.org/samba/security/CVE-2022-32745.html

Search for package or bug name: Reporting problems