DescriptionCommand injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1027154

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-mysql (PTS)buster5.3.0-1vulnerable
sid, trixie, bookworm8.1.0-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - puppet-module-puppetlabs-mysql <no-dsa> (Minor issue)
[bullseye] - puppet-module-puppetlabs-mysql <no-dsa> (Minor issue)
[buster] - puppet-module-puppetlabs-mysql <no-dsa> (Minor issue) (v13.0.0) (v13.0.0) (v13.0.0) (v13.0.0)

Search for package or bug name: Reporting problems