CVE-2022-32893

NameCVE-2022-32893
DescriptionAn out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3087-1, DSA-5219-1, DSA-5220-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.0-1~deb10u1fixed
bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.0-1~deb11u1fixed
bookworm, sid2.38.0-3fixed
wpewebkit (PTS)bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.0-1~deb11u1fixed
bookworm, sid2.38.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.36.7-1~deb10u1DLA-3087-1
webkit2gtksourcebullseye2.36.7-1~deb11u1DSA-5219-1
webkit2gtksource(unstable)2.36.7-1
wpewebkitsourcebullseye2.36.7-1~deb11u1DSA-5220-1
wpewebkitsource(unstable)2.36.7-1

Notes

https://wpewebkit.org/security/WSA-2022-0008.html

Search for package or bug name: Reporting problems