CVE-2022-32981

NameCVE-2022-32981
DescriptionAn issue was discovered in the Linux kernel through 5.18.3 on powerpc 32-bit platforms. There is a buffer overflow in ptrace PEEKUSER and POKEUSER (aka PEEKUSR and POKEUSR) when accessing floating point registers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.320-2vulnerable
buster4.19.235-1vulnerable
buster (security)4.19.232-1vulnerable
bullseye5.10.106-1vulnerable
bullseye (security)5.10.120-1vulnerable
bookworm, sid5.18.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.18.5-1unimportant

Notes

[stretch] - linux <ignored> (powerpc not supported in LTS)
https://git.kernel.org/linus/8e1278444446fc97778a5e5c99bca1ce0bbc5ec9
https://www.openwall.com/lists/oss-security/2022/06/14/3
32-bit powerpc not a release architecture

Search for package or bug name: Reporting problems