CVE-2022-3352

NameCVE-2022-3352
DescriptionUse After Free in GitHub repository vim/vim prior to 9.0.0614.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3204-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u4fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0813-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster2:8.1.0875-5+deb10u4DLA-3204-1
vimsource(unstable)2:9.0.0626-1unimportant

Notes

https://huntr.dev/bounties/d058f182-a49b-40c7-9234-43d4c5a29f60
https://github.com/vim/vim/commit/ef976323e770315b5fca544efb6b2faa25674d15 (v9.0.0614)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems