CVE-2022-33743

NameCVE-2022-33743
Descriptionnetwork backend may cause Linux netfront to use freed SKBs While adding logic to support XDP (eXpress Data Path), a code label was moved in a way allowing for SKBs having references (pointers) retained for further processing to nevertheless be freed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5191-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.235-1vulnerable
buster (security)4.19.249-2vulnerable
bullseye5.10.127-1vulnerable
bullseye (security)5.10.136-1fixed
bookworm, sid5.18.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebullseye5.10.127-2DSA-5191-1
linuxsource(unstable)5.18.14-1

Notes

https://xenbits.xen.org/xsa/advisory-405.html

Search for package or bug name: Reporting problems