CVE-2022-33981

NameCVE-2022-33981
Descriptiondrivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3065-1, DSA-5173-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.235-1vulnerable
buster (security)4.19.249-2fixed
bullseye5.10.127-1fixed
bullseye (security)5.10.136-1fixed
bookworm, sid5.18.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch4.9.320-2DLA-3065-1
linuxsourcebuster4.19.249-2DSA-5173-1
linuxsourcebullseye5.10.113-1
linuxsource(unstable)5.17.6-1

Notes

https://www.openwall.com/lists/oss-security/2022/04/28/1
https://git.kernel.org/linus/233087ca063686964a53c829d547c7571e3f67bf (5.18-rc5)

Search for package or bug name: Reporting problems