CVE-2022-34000

NameCVE-2022-34000
Descriptionlibjxl 0.6.1 has an assertion failure in LowMemoryRenderPipeline::Init() in render_pipeline/low_memory_render_pipeline.cc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jpeg-xl (PTS)bookworm0.7.0-1fixed
sid0.7.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jpeg-xlsource(unstable)(not affected)

Notes

- jpeg-xl <not-affected> (Fixed before initial upload to unstable, only affected experimental, bug #1013265)
https://github.com/libjxl/libjxl/issues/1477
https://github.com/libjxl/libjxl/commit/aff17c4a57eb1e4d7ef00ea728d33cdb5b2ca9da

Search for package or bug name: Reporting problems