CVE-2022-3433

NameCVE-2022-3433
DescriptionThe aeson library is not safe to use to consume untrusted JSON input. A remote user could abuse this flaw to produce a hash collision in the underlying unordered-containers library by sending specially crafted JSON data, resulting in a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009678

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
haskell-aeson (PTS)buster1.3.1.1-3vulnerable
bullseye1.4.7.1-2vulnerable
bookworm, sid2.0.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
haskell-aesonsource(unstable)2.0.3.0-11009678

Notes

[bullseye] - haskell-aeson <no-dsa> (Minor issue)
[buster] - haskell-aeson <no-dsa> (Minor issue)
[stretch] - haskell-aeson <no-dsa> (Minor issue)
https://cs-syd.eu/posts/2021-09-11-json-vulnerability
https://github.com/haskell/aeson/issues/864
https://github.com/haskell/aeson/commit/582a844d8028f62e409048a4caae187b27e8e697 (v2.0.1.0)

Search for package or bug name: Reporting problems