CVE-2022-3520

NameCVE-2022-3520
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2fixed
sid, trixie2:9.0.1894-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.0813-1unimportant

Notes

https://huntr.dev/bounties/c1db3b70-f4fe-481f-8a24-0b1449c94246
https://github.com/vim/vim/commit/36343ae0fb7247e060abfd35fb8e4337b33abb4b (v9.0.0765)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems