CVE-2022-35205

NameCVE-2022-35205
DescriptionAn issue was discovered in Binutils readelf 2.38.50, reachable assertion failure in function display_debug_names allows attackers to cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binutils (PTS)buster2.31.1-16vulnerable
bullseye2.35.2-2vulnerable
bookworm2.40-2fixed
sid, trixie2.42.50.20240618-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binutilssource(unstable)2.38.50.20220627-1unimportant

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=29289
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=e3e5ae049371a27fd1737aba946fe26d06e029b5
binutils not covered by security support

Search for package or bug name: Reporting problems