CVE-2022-35206

NameCVE-2022-35206
DescriptionNull pointer dereference vulnerability in Binutils readelf 2.38.50 via function read_and_display_attr_value in file dwarf.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binutils (PTS)buster2.31.1-16vulnerable
bullseye2.35.2-2vulnerable
bookworm2.40-2fixed
sid, trixie2.42-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binutilssource(unstable)2.38.50.20220627-1unimportant

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=29290
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=e98e7d9a70dcc987bff0e925f20b78cd4a2979ed
binutils not covered by security support

Search for package or bug name: Reporting problems