CVE-2022-35229

NameCVE-2022-35229
DescriptionAn authenticated user can create a link with reflected Javascript code inside it for the discovery page and send it to other users. The payload can be executed only with a known CSRF token value of the victim, which is changed periodically and is difficult to predict.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3390-1
Debian Bugs1014992

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zabbix (PTS)buster1:4.0.4+dfsg-1vulnerable
buster (security)1:4.0.4+dfsg-1+deb10u5fixed
bullseye1:5.0.8+dfsg-1vulnerable
bookworm1:6.0.14+dfsg-1fixed
sid, trixie1:7.0.0+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zabbixsourceexperimental1:6.0.6+dfsg-1
zabbixsourcebuster1:4.0.4+dfsg-1+deb10u1DLA-3390-1
zabbixsource(unstable)1:6.0.7+dfsg-21014992

Notes

[bullseye] - zabbix <no-dsa> (Minor issue)
https://support.zabbix.com/browse/ZBX-21306
Fixed in: https://git.zabbix.com/projects/ZBX/repos/zabbix/commits/b546c3f10ce98b0c914e5fc4114bd43042880c3c (5.0.25rc1)

Search for package or bug name: Reporting problems