CVE-2022-35414

NameCVE-2022-35414
Descriptionsoftmmu/physmem.c in QEMU through 7.0.0 can perform an uninitialized read on the translate_fail path, leading to an io_readx or io_writex crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster, buster (security)1:3.1+dfsg-8+deb10u8vulnerable
bullseye (security), bullseye1:5.2+dfsg-11+deb11u2vulnerable
bookworm, sid1:7.0+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)1014958

Notes

[bullseye] - qemu <no-dsa> (Minor issue)
https://gitlab.com/qemu-project/qemu/-/issues/1065
https://github.com/qemu/qemu/commit/418ade7849ce7641c0f7333718caf5091a02fd4c
https://sick.codes/sick-2022-113

Search for package or bug name: Reporting problems