CVE-2022-3559

NameCVE-2022-3559
DescriptionA vulnerability was found in Exim and classified as problematic. This issue affects some unknown processing of the component Regex Handler. The manipulation leads to use after free. The name of the patch is 4e9ed49f8f12eb331b29bd5b6dc3693c520fddc2. It is recommended to apply a patch to fix this issue. The identifier VDB-211073 was assigned to this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)buster4.92-8+deb10u6vulnerable
buster (security)4.92-8+deb10u7vulnerable
bullseye4.94.2-7vulnerable
bookworm, sid4.96-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.96-4

Notes

[bullseye] - exim4 <no-dsa> (Minor issue)
[buster] - exim4 <no-dsa> (Minor issue)
https://bugs.exim.org/show_bug.cgi?id=2915
https://git.exim.org/exim.git/commit/4e9ed49f8f12eb331b29bd5b6dc3693c520fddc2

Search for package or bug name: Reporting problems