CVE-2022-3560

NameCVE-2022-3560
DescriptionA flaw was found in pesign. The pesign package provides a systemd service used to start the pesign daemon. This service unit runs a script to set ACLs for /etc/pki/pesign and /run/pesign directories to grant access privileges to users in the 'pesign' group. However, the script doesn't check for symbolic links. This could allow an attacker to gain access to privileged files and directories via a path traversal attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1030168

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pesign (PTS)buster0.112-5vulnerable
bookworm, bullseye0.112-6vulnerable
sid, trixie116-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pesignsource(unstable)116-11030168

Notes

[bookworm] - pesign <no-dsa> (Minor issue)
[bullseye] - pesign <no-dsa> (Minor issue)
[buster] - pesign <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2023/01/31/6
https://www.openwall.com/lists/oss-security/2023/02/01/2
https://github.com/rhboot/pesign/commit/d8a8c259994d0278c59b30b41758a8dd0abff998 (116)

Search for package or bug name: Reporting problems