CVE-2022-35978

NameCVE-2022-35978
DescriptionMinetest is a free open-source voxel game engine with easy modding and game creation. In **single player**, a mod can set a global setting that controls the Lua script loaded to display the main menu. The script is then loaded as soon as the game session is exited. The Lua environment the menu runs in is not sandboxed and can directly interfere with the user's system. There are currently no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1017548

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
minetest (PTS)buster, buster (security)0.4.17.1+repack-1+deb10u1vulnerable
bullseye (security), bullseye5.3.0+repack-2.1+deb11u1vulnerable
bookworm, sid5.6.1+dfsg+~1.9.0mt8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
minetestsource(unstable)5.5.0+dfsg+~1.9.0mt4+dfsg-21017548

Notes

[bullseye] - minetest <no-dsa> (Minor issue)
[buster] - minetest <no-dsa> (Minor issue)
https://github.com/minetest/minetest/security/advisories/GHSA-663q-pcjw-27cc
https://github.com/minetest/minetest/commit/da71e86633d0b27cd02d7aac9fdac625d141ca13 (5.6.0)

Search for package or bug name: Reporting problems