CVE-2022-36059

NameCVE-2022-36059
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1018970

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-matrix-js-sdk (PTS)buster0.9.2-1vulnerable
bullseye9.3.0+~cs9.9.16-2vulnerable
sid9.11.0+~cs9.9.16-2vulnerable
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:102.3.0-1~deb10u1fixed
bullseye1:91.13.0-1~deb11u1fixed
bullseye (security)1:102.3.0-1~deb11u1fixed
bookworm, sid1:102.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-matrix-js-sdksource(unstable)(unfixed)1018970
thunderbirdsourcebuster(not affected)
thunderbirdsourcebullseye(not affected)
thunderbirdsource(unstable)1:102.2.1-1

Notes

[bullseye] - node-matrix-js-sdk <no-dsa> (Minor issue)
[buster] - node-matrix-js-sdk <no-dsa> (Minor issue)
[bullseye] - thunderbird <not-affected> (Only affects ESR102)
[buster] - thunderbird <not-affected> (Only affects ESR102)
https://www.mozilla.org/en-US/security/advisories/mfsa2022-38/#CVE-2022-36059
https://matrix.org/blog/2022/08/31/security-releases-matrix-js-sdk-19-4-0-and-matrix-react-sdk-3-53-0
https://github.com/matrix-org/matrix-js-sdk/commit/8716c1ab9ba93659173b806097c46a2be115199f (v19.4.0)

Search for package or bug name: Reporting problems