CVE-2022-36087

NameCVE-2022-36087
DescriptionOAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1019710

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-oauthlib (PTS)buster2.1.0-1fixed
bullseye3.1.0-2fixed
bookworm, sid3.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-oauthlibsourcebuster(not affected)
python-oauthlibsourcebullseye(not affected)
python-oauthlibsource(unstable)3.2.1-11019710

Notes

[bullseye] - python-oauthlib <not-affected> (Vulnerable code introduced later)
[buster] - python-oauthlib <not-affected> (Vulnerable code introduced later)
https://github.com/oauthlib/oauthlib/security/advisories/GHSA-3pgj-pg6c-r5p7
Introduced with: https://github.com/oauthlib/oauthlib/commit/2b8a44855a51ad5a5b0c348a08c2564a2e197ea2 (v3.1.1)
Fixed by: https://github.com/oauthlib/oauthlib/commit/e514826eea15f2b62bbc13da407b71552ef5ff4c
Fixed by: https://github.com/oauthlib/oauthlib/commit/5d85c61998692643dd9d17e05d2646e06ce391e8

Search for package or bug name: Reporting problems