CVE-2022-36280

NameCVE-2022-36280
DescriptionAn out-of-bounds(OOB) memory access vulnerability was found in vmwgfx driver in drivers/gpu/vmxgfx/vmxgfx_kms.c in GPU component in the Linux kernel with device file '/dev/dri/renderD128 (or Dxxx)'. This flaw allows a local attacker with a user account on the system to gain privilege, causing a denial of service(DoS).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3349-1, DLA-3403-1, DSA-5324-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)bullseye (security), bullseye5.10.218-1fixed
bookworm6.1.94-1fixed
bookworm (security)6.1.90-1fixed
trixie6.9.8-1fixed
sid6.9.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster4.19.282-1DLA-3403-1
linuxsourcebullseye5.10.162-1DSA-5324-1
linuxsource(unstable)6.1.4-1
linux-5.10sourcebuster5.10.162-1~deb10u1DLA-3349-1

Notes

https://bugzilla.openanolis.cn/show_bug.cgi?id=2071
https://git.kernel.org/linus/4cf949c7fafe21e085a4ee386bb2dade9067316e

Search for package or bug name: Reporting problems